airGuitar風味のMIDIコントローラの組み立て

2012年10月20日

MIDIコントローラの専用基板の組み立て方法です。

AG00

1. 基板の組み立て方

注意:カバーを付ける場合には、基板上のパーツの高さは6mm以下にして下さい。(タクトスイッチを除く)

(1) パーツを確認する

AG01

(2) 抵抗を取り付ける その1

AG02

(3) 抵抗を取り付ける その2

AG03

(4) ダイオードを取り付ける

AG04

(5) 積層セラミックコンデンサを取り付ける

AG05

(6) LEDとCPUを取り付ける (カバーを付ける場合にはCPUを直付けにします。

AG06

(7) 電解コンデンサを取り付ける

AG07

(8) タクトスイッチを取り付ける

AG08

(9) USBコネクタとポリヒューズを取り付ける

カバーを付ける場合には、ポリヒューズは寝かせて付けること

AG09

(10) 距離センサ用のコネクタを取り付ける(色の順番注意!

AG10

(11) 基板のすみに距離センサをネジ止めする

AG11

(12) ケーブルをまとめて完成

AG12

2. カバーを取り付ける場合

予め、基板の裏側の余分なリード線は切り取っておきます。

※USBコネクタ、タクトスイッチ、CPUコネクタなど

(1) 必要なパーツの確認

AG20

(2) アクリルの保護紙をはがす (写真はプロトタイプです。頒布したものは文字がありません

AG21

(3) 距離センサを下のカバーにネジ止めする

AG22

(4) 上のカバーにスペーサをネジ止めする

AG23

(5) 下のカバーからネジ止めする その1

AG24

(6)下のカバーからネジ止めする その2

AG25

(7) 完成

IMGP7655

  1. maguo
    2012年08月26日 2012年08月26日 | #1

    本日、大垣でairGuitarキットを購入させていただきました。ありがとうございました。早速組み立ててみたのですが、LEDは点灯するものの、GarageBandでMIDIコントローラとして認識されません。もしかしてCPUにソフトの書き込みが必要なんですかね?

  2. 2012年08月27日 2012年08月27日 | #2

    ご購入ありがとうございます。
    CPUにファームウエアは書き込み済みです。
    ・センサに反応して、中央のLEDが点滅しますか?点滅しない場合は部品取り付けミスの可能性があります
    ・GarageBandはMac版でしょうか? iPadでしょうか?
    ・接続にHUBを使っていますか?使っているなら直結で試して下さい。

  3. egupyon
    2012年08月27日 2012年08月27日 | #3

    私も先程、組み上げました。

    USBに繋ぐと、LEDが点灯し、WINDOWS7だとドライバーが導入されたみたいですが、!マークがついています。

    C3とかのボタン押しながら、センサーに手をかざすと、もう一つのLEDが反応します。

    GarageBandはiPadで行う予定ですが、どう設定するといいのでしょうか?

    動作確認手順もご紹介していただけると助かります。

    以上、よろしくお願い致します。

    写真だと、SWみたいなのがついていますが、この辺の配線しなくても大丈夫なのでしょうか?

  4. maguo
    2012年08月27日 2012年08月27日 | #4

    返信ありがとうございました。
    センサに反応して中央のLEDが点滅します。
    GarageBandはiPad版です。
    HUBは使っていません。
    ハンダ付けはあまり経験がない嫁がやりましたので、あまりキレイではありませんが、つながってしまっているような部分はありません。熱でCPUがダメになってしまったのでしょうか?(T_T)

  5. maguo
    2012年08月27日 2012年08月27日 | #5

    ちなみにUSBケーブルも2本試しました。

  6. 2012年08月27日 2012年08月27日 | #6

    egupyonさん
    maguoさん

    センサに反応してLEDが点滅するのということは、ハードは正常に動作していると思われます。
    その状態でiPadにつなげば、そのままGarageBandで認識されるはずです。
    もしかして、iPad3+カメラコネクションキットでお使いでしょうか?
    iPad, iPad2では試していますが、手元にないため、iPad3では試していません。

  7. 2012年08月27日 2012年08月27日 | #7

    ちなみに、Win7も手元にないので試してませんでした。
    最初にUSBを差し込んだ時に、なにかドライバ入れろってダイアログでませんでしたか?

  8. egupyon
    2012年08月28日 2012年08月28日 | #8

    はい、新しいiPad(iPad3)とカメラコネクションキットで動作させようとしています。
    Mac OSX Moutaion Lionでも動作するんですかね?
    Win7では、ドライバーが自動でダウンロードされたのですが、認識しているのですが、何故か!マーク付きになってなんともいえない感じです。

  9. maguo
    2012年08月28日 2012年08月28日 | #9

    当方も新しいiPad(iPad3)です。認識された場合は何か表示がされるのでしょうか?

  10. 2012年08月28日 2012年08月28日 | #10

    どうもソフトに問題があったようです。調べますので少々お待ち下さい。

  11. 2012年08月28日 2012年08月28日 | #11

    デバイスの確認方法ですが、次の方法が有効です。
    (1) iPad
     無料の「Midi Monitor」というソフトを試して下さい。
      DEVICEが認識されると画面右上の部分に次のように表示されます。
      MIDI Output Found: AirGuitar
      MIDI Input Found: AirGuitar
      入出力されるMIDIメッセージも画面左上の部分に表示されます。
     ※GarageBandでは何も表示されません。
    (2) MacOSX
     システムプロファイラでハードウエアの項目に表示されます。
    (3) Windows
     デバイスマネージャから確認します。
     サウンド、ビデオ、およびゲームコントローラの下に「USBオーディオデバイス」としてairGuitarが表示されます。
     また、正しくドライバがインストールされていない場合ば、「!」が表示されます。

  12. egupyon
    2012年08月28日 2012年08月28日 | #12

    iPad用のMidi Touchを探してみましたが、無料のはないみたいですね。
    1700円の値段のついたのはありましたが。。。

    その他の手段で確認して見ます。
    ちなみにWindows 7の64bit環境だったりするので、もしかしたら影響あるかもしれません。

  13. 2012年08月28日 2012年08月28日 | #13

    あ、MIDI monitorの間違えでした。

    http://iosmidi.com/apps/midi-monitor/

    ごめんなさい。

  14. 2012年08月28日 2012年08月28日 | #14

    取り急ぎ、V-USBを古いバージョンに戻して、Windows XP / MacOSX Lion / iPad2で動作確認しました。

    http://morecatlab.akiba.coocan.jp/lab/index.php/2012/08/airguitar/

    どなたか手元にISPライタのある方で試して頂けませんでしょうか?
    動作の確認が取れましたら、ライタのない方にも対応しますので、少々お待ち下さい。

  15. maguo
    2012年08月28日 2012年08月28日 | #15

    iPad3でMIDI nonitorを試してみましたが、認識されないようです。XPと7も試してみます。

  16. maguo
    2012年08月28日 2012年08月28日 | #16

    XPで試してみました。デバイスマネージャで、「USBオーディオデバイス」が表示されますが、「!」がついてしまっています。オンラインでドライバの更新をしましたが、見つからないようです。
    Vistaと7(32bit)では、デバイスマネージャに「AirGuitar」と表示されますが、やはり「!」がついてしまい、更新してもうまくいきませんでした。
    いずれについてもプロパティを見ると、「このデバイスを開始できません(コード10)」と表示されます。
    残念ながらIPSライタは持ってませんm(_ _)m

  17. egupyon
    2012年08月28日 2012年08月28日 | #17

    ISPライターは自宅に帰ればありますので、試してみます。

  18. egupyon
    2012年08月28日 2012年08月28日 | #18

    ISPピンを立てて、ファーム書きました。
    すると、Windows 7 64Bitでもちゃんと認識(!マークなし)されました。
    iPad3でMIDI Monitorで認識されましたが、MIDI Output found: AirGuitarになってしまい。
    Output Deviceとして認識されちゃってて、ボタン押しても、LEDが点滅しなくなり、iPad上の鍵盤を叩くとLEDが光るという逆の動作になっています。USBを抜くと、MIDI Outputr lost:ArGuitarが出た後、MIDI Input found: AirGuitarと抜いているのに出る感じです。

  19. egupyon
    2012年08月28日 2012年08月28日 | #19

    ああ、ごめんなさい。
    ファームウェアのファイルが2つあることを思い出し、eepromも焼いたら、OKになりました。

  20. 2012年08月28日 2012年08月28日 | #20

    egupyonさん、報告ありがとうございます。助かりました。
    eepromは2バイトだけ使っています。あとで注意を書いておきます。

    概ね新しいファームで良好そうですが、もう少し動作の確認を待ってからISPのない人に対応します。
    maguoさん、もう少しお待ち下さい。

  21. 2012年08月29日 2012年08月29日 | #21

    私自身でも、新しいファームウエアとiPad3 およびWin7/32bitで動作確認出来ました。

    maguoさんには個別に連絡いたします。

    もし、他の方でファームウエアの交換を希望される場合には連絡下さい。

  22. maguo
    2012年08月31日 2012年08月31日 | #22

    本日新しいCPUを受け取りました。
    無事動作いたしました。
    大変親切な対応をありがとうございましたm(_ _)m

  23. 2012年09月01日 2012年09月01日 | #23

    連絡ありがとうございます。
    また、ご面倒をおかけしてすみませんでした。

    無事動いて良かったです。

コメントは受け付けていません。